11

RumpelstiltskinRSS is a web based RSS reader for your Gengo Jobs RSS. After some one-time steps, you can use any browser on any device to alert you for new jobs. As a bonus, RumpelstiltskinRSS does some filtering for you so you will only be alerted if the size and level of the job meet your preferences, taking the time of day into account.

I optimized RumpelstiltskinRSS for my own needs, but tried to make it so that it can be used by all translators. You can find RumpelstiltskinRSS at http://rumpelstiltskin.appje.nl/rss/. For a description how to use it, follow the Introduction link.

Note that you can set the refresh interval to either 31 or 62 seconds. Use 31 for optimal chances to grab a job, without breaching Gengo's demand to access your Jobs RSS at most twice per minute. Or use 62 to test if RumpelstiltskinRSS suits you, while still running your current RSS reader (set to check at most once per minute) on another device.

305 comments

  • 0
    Avatar
    Cheryl

    Thank you so much! I didn't get an email (checked spam and everything too). I appreciate your taking the time to work on this with me. I'll try your recommendations. Are the memory issues your talking about more about RAM, video, etc (what kind of memory needs more space)? That may be something I can fix as well on my pc.

  • 0
    Avatar
    Alexander

    It's just a wild guess, but adding RAM can never hurt. Also you could check if the hard disk has enough free space. I think the recommendation is that at least 30% of the disk should be free so the system has enough space to do all kinds of work quickly.

    Also, if you leave many tabs open in your browser, consider closing some that you do not really need, and if you have many programs running at the same time, consider quitting some of them to free up memory.

  • 0
    Avatar
    Cheryl

    Okay, just tested a 600 unit job at 2 seconds, it took me to the intro page (this is your workbench, etc...). I completed all that, then went back and re-tested. It went directly to the job.

    I then tested a heavier file (paid $35, so fairly sizable), and it worked fine set at 2 seconds.

    So, I changed the setting to 1 second, retested the heavy file and it worked fine.

    I'll wait for a job to come through while I'm near my computer to see what happens (one came through when I went to check on my daughter.

  • 0
    Avatar
    Cheryl

    A job just came through, no sound played. But when it went to the landing page, I received 'access denied' message.

  • 0
    Avatar
    Alexander

    Thank you for doing the extra tests. Looks like my guess about a memory issue was wrong. Perhaps the problem is related to the recent update of the server scripts after all.

    Today and tomorrow I am too busy, but this weekend I will create a separate environment with the previous scripts. If that solves the problem, I will step by step reintroduce the changes I made in the recent update to find out which change caused this issue.

  • 0
    Avatar
    Cheryl

    For some bizarre reason, it just worked about an hour ago. A Christmas miracle! :-)

  • 0
    Avatar
    Alexander

    That's great! But if it happens again, don't hesitate to contact me about it again because this may be an issue for others as well.

  • 0
    Avatar
    Cheryl

    Hi Alex,

    SO sorry, the job that I snagged when the RSS worked one time must have been a one-off, because it's gone back to not working. I've tried it on Firefox and Chrome. What do you need from me to try and fix this?
    Thanks!

  • 0
    Avatar
    Alexander

    Hi Cheryl,

    Like I wrote on December 19, 2019 17:24, perhaps the problem is related to the recent update of the server scripts after all. This weekend, I will create a separate environment with the previous scripts and keep you informed how to use it.

  • 0
    Avatar
    Alexander

    Hi Cheryl,

    I restored the scripts from before the recent update at http://rmpl.nl/index_test.php. Please let me know if you still have this problem when you use this version.

  • 0
    Avatar
    Cheryl

    I'm running the new one now. Here's hoping. Are you logging when jobs come through as well, so I know what I've missed? Thanks!

  • 0
    Avatar
    Cheryl

    No sound when job came through on the link you just gave me, and no sound on dummy job either (I tested after the 'real' job came through). Usually, dummy jobs have always worked.

  • 0
    Avatar
    Alexander

    Hi Cheryl,

    Thanks for doing the test. I restored the exact scripts that worked for you before the recent update, so it looks like this weird behaviour is not related to the scripts. Apparently, it's just a coincidence that it started around the time of the update.

    I tend to return to my theory it somehow has to do with tight memory on your computer. I can think of only a few more things you could try:

    - Test with the dummy job both on rmpl.nl/index_test.php and rmpl.nl. If my theory is correct, you should get the sound in both cases or not at all. If you get the sound in one version but not in the other, the possibility that the update has to do with it is still open.

    - Test on a different computer, to see if the problem is related to your unique configuration.

    - Create a new account, to see if there is an issue with your preferences. (I don't think so, since I already tested with your settings, but that was on my computer, not yours.)

    - Uncheck "When a new job is found, after .. seconds go to workbench and halt", since the combination of the sound and this option is more demanding (also in terms of memory) than only the sound.

    - Use the RumpelstiltskinRSS iOS or Android app version, since they are (as far as I can see) more reliable, and I am in more control of the details should you still experience a problem.

  • 0
    Avatar
    Alexander

    Just to move with the times, I asked my provider to enable SSL-encrypted connection for rmpl.nl, so you can now use the address https://www.rmpl.nl for a secure connection.

    In fact, no sensitive information is exchanged between your computer and my server, so it's not a big deal if you keep using http://www.rmpl.nl, but if you feel more comfortable using a secure connection, you now have the option.

    If you experience any problem when using https://www.rmpl.nl, please let me know.

  • 0
    Avatar
    Cheryl

    For the last month or so, the RSS has been pretty random. Sometimes I get a sound, more often I don't. I've tried all the steps on the checklist, but nothing. Any ideas? Thanks!

  • 0
    Avatar
    Alexander

    Hi Cheryl - Alas, I am clueless. I hope others with similar experiences will chime in so we can look for a pattern.

    As a workaround, if you have access to an iOS or Android device, you could use the app version for the sound, along with the browser version to actually grab a job.

  • 0
    Avatar
    Cheryl

    Hi Alex,

    I have the app on my phone and my iPad. I've tested it with dummy jobs and it works, but I don't know if it will work on real jobs. Does the phone/iPad need to be awake at all times? The instructions say not to push the home button, but I'm on a phone with no buttons at all- what does that mean for me? Can I do other things on my device while the app is running or will that keep the app from running? Thanks!

    ps- the browser version is still weird- sometimes I get sounds, sometimes not.

  • 0
    Avatar
    Alexander

    Hi Cheryl,

    If it works for dummy jobs, it will work for real jobs as well. My server provides the app with a list of jobs, and the app notifies you when that list is not empty. So merely by being on the list, the real jobs will trigger the notification, just like the dummy job.

    On my stoneaged iOS device, pushing the home button is the way to leave an app so you can start using another one. Unlike the Android version, which keeps running no matter what, the iOS app should be active or it won't work at all, due to restrictions by Apple. It works fine in the sleep mode, though, and perhaps you could also use Split View or Slide Over to run the app while you are doing other things on your device.

    I never tested Split View / Slide Over, since my device doesn't support it, but if your does, you could try using the app in these modes and see if it keeps notifying about dummy jobs.

    PS - I find it hard to believe you are the only one who experiences this weird behaviour of the browser version, and I still hope others will chime in so we can look for a pattern.

  • 0
    Avatar
    Cheryl

    Thanks for the tip on split view- I'll give that a shot.

  • 0
    Avatar
    Cheryl

    I do get 'bad gateway' errors at times (I assume that it's when it tries to check for jobs?). If that helps. I've also gotten (when it goes over to the workbench) 'access denied', and when I refresh, the job's been taken.

    I also get server timeouts several times a day.

    Edited by Cheryl
  • 0
    Avatar
    Alexander

    Hi Cheryl,

    Just this morning another user contacted me about an issue that may or may not be related to these 'bad gateway' errors. I asked my provider if they could see anything special on their side. They replied everything seems to be fine, though there are error messages about my server not being able to reach Gengo’s.

    I did see these messages every now and then in the past, but not as many as today. So I asked my provider to check again if really nothing has changed on their side. (Of course, it could also be a temporary issue on Gengo’s side, but I don’t think that’s very likely.)

    I will keep you informed.

  • 0
    Avatar
    Alexander

    Hi Cheryl,

    My provider checked again but does not see anything special on the server. Still I feel something on the server has to do with it. It might simply be the number of users, causing more traffic than in the past.

    To test this, could you please use http://appje.nl/rmpl/ for a while? It is a copy of rmpl.nl, except that it runs on a different server, hosted by a different provider.

    While I stopped running rmpl on appje.nl long ago because this server couldn’t handle the growing user base, it should be possible to run this little test because the number of users is limited. I disabled the possibility to create a new account, and manually added your account, my own and the account of the other user who reported a similar issue like the one you experience.

    Anyone else who has problems which may be due to rmpl.nl not being able to reach Gengo: please contact me and I will duplicate your account to this test site, so we can see if that makes a difference.

  • 0
    Avatar
    Cheryl

    Is the RSS feed down? I am continually getting 'Connection timed out' messages. 

    Thanks!

  • 0
    Avatar
    Cheryl

    Is the RSS feed down? I am continually getting 'Connection timed out' messages. 

    Thanks!

  • 0
    Avatar
    Alexander

    Hi Cheryl,

    Are you referring to the regular site rmpl.nl or the test site appje.nl/rmpl? I don't see these 'Connection timed out' messages on either site.

    When I set up the test site, I planned to run the test only for a few weeks, so I added a line that the site should disable itself as of April, 1, and then forgot about it. Sorry for not mentioning this before. While I don't believe this is related, I just changed that so the test site will remain accessible until December, 31.

    Please let me know if you still get these 'Connection timed out' messages and if so, which site you are using.

  • 0
    Avatar
    Cheryl

    I've been running one RSS version on Firefox and the other on Chrome. I noticed that the test site had stopped working, no problem. AS someone who usually can spot patterns in phenomena, there seems to be no discernible pattern at all as to when it does/doesn't work. I've had it open on my iOS devices as well, and nothing. Again, it's very difficult when there are so few files in a day to try and spot what's going on. 

    I used to get 1-2 files a day, now I'm considering myself really lucky if I get that in a week. (it's not you, it's just the situation- you've always been a rock star :-))

  • 0
    Avatar
    Cheryl

    Okay, so just now I got this message on the 'normal' site, with Firefox:

    Unable to connect

    Firefox can’t establish a connection to the server at www.rmpl.nl.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

  • 0
    Avatar
    Alexander

    Hi Cheryl,

    Thanks for the update.

    I tested right after your post and rmpl.nl still works fine for me. If appje.nl/rmpl works fine for you too while you get these Unable to connect messages on rmpl.nl, this confirms my suspicion the problems you experience are at least in part due to heavy server load.

    While I don't understand why this affects you more than others, I guess the user base has simply grown so large that some critical number has been exceeded and the server has problems handling all requests.

    I plan to work harder on monetizing my tool so I can move to a better performing server/provider. I have several ideas how to proceed but it takes time to get the details right. I will keep you posted on this forum.

  • 0
    Avatar
    Cheryl

    I'm just grateful at how responsive you are- it makes a huge difference in my frustration level to know that you're on the case! Your tool is beyond valuable, I'd be willing to pay to use it. 

  • 0
    Avatar
    Cheryl

    Today, I've gotten a series of errors that makes me think it's a problem at Gengo, not with the RSS< but I thought you'd probably like to know. I'll post them as I get them (unless you tell me otherwise) 

    Error 508
    Resource Limit Is Reached

    The website is temporarily unable to service your request as it exceeded resource limit. Please try again later.

Please sign in to leave a comment.